• Shoutbox
    Active Users: 0
  • Notice: N/A
  • Active Users
  • There are currently no users chatting.
Results 1 to 7 of 7
  1. #1

    Making a vent grill you can shoot through (MoH Radiant)

    Just curious as I was making a vent on a map and found that the vent grill texture I was using was not allowing me to shoot through it. An example of what I was trying to do is like in the Allied Assault campaign in m2l3 where you crawl through the vent and at some points can shoot through the grates to the rooms below.

    The textures I am using are ventgrill and nodraw


  2. #2
    For my vent grills in test_bocage I added the fence surface flag: https://image.ibb.co/chQn1p/ventgrill.jpg

    Try doing that to yours to see if it helps.

    Remember, open up your Surface Properties, then middle mouse click on your ventgrill texture to load them into the window, and then click the fence flag, and then hit apply in the window.

    If it works, it should let you shoot through the holes in the grill if you're facing the grill texture itself. If you are firing out the nodraw side (only one side needs to be set to ventgrill), then you should be able to shoot through it all (which is what they did for m2l3 for ceiling grates).

    If you want it so the player can shoot only through the holes (and hit the grill itself) you can make two brushes each with only one side painted as ventgrill but both facing one another like so: https://image.ibb.co/ktOh1p/grills.jpg (obviously they need to be touching each other but I separated them for the pic). This is taken from my test_bocage map.

  3. #3
    Thanks for the advice, another question I have is an issue with nodraw when I use a vent grill or wire mesh for a catwalk. If one side has nodraw then on Allied Assault the side with nodraw will appear as if the mesh isnt there. On Spearhead however if one side is no-draw both sides still show the grill or wire mesh texture. Any reason why this happens, and if so how can I make it so the wire mesh shows on both sides for Allied Assault?

    I'll attach a picture of my issue


    as you can see in the picture the side which has no draw is not visible (on Allied Assault)

  4. #4
    Yeah, this is an issue that I've found in the past and never really explored why it happens. The textures in question do not cause an issue on stock maps which almost suggests a compilation issue, and to add further I tried recompiling the stock maps and the textures stopped working properly, but I don't see why some textures are fine and others are not. Looking at the shader file shows they have 'cull none' which is what is used if you want to see both sides of a brush face, which is correct (and again, works fine on other textures).

    I think I may share this issue with xnull to see if anyone there can shed any insight.

  5. #5
    Aside from stock maps, I found that this custom map has a catwalk that somehow wasn't bugged in AA or Spearhead
    So is there a possibility changing the compile method may fix this?


    conveniently this custom map came with a .map file too

  6. #6
    Okay, a quick look at the map "Clifftop" that The Shadow linked us to shows that the creator "[lol]LCpl_Ramah" actually used the texture "general_industrial/deckgrate_set1" and not "general_industrial/ventgrill".
    This texture comes with Allied Assault in the pak2.pk3 file.

    The surface flags selected are "no marks", "fence" "playerclip", "monsterclip" and "detail".

    I tested it in both AA and SH where it worked perfectly in both.

    The shaders are:
    qer_editorimage textures/general_industrial/deckgrate_set1.tga
    qer_keyword wall
    qer_keyword floor
    qer_keyword masked
    qer_keyword rusted
    qer_keyword metal
    surfaceParm fence
    surfaceparm metal
    surfaceParm nomarks
    surfaceParm grill
    // surfaceparm alphashadow
    cull none
    map textures/general_industrial/deckgrate_set1.tga
    alphaFunc GE128
    map $lightmap

    as opposed to:

    qer_editorimage textures/general_industrial/vent_grill1.tga
    qer_keyword wall
    qer_keyword metal
    qer_keyword rusted
    qer_keyword m5
    qer_keyword m6
    qer_keyword masked
    surfaceParm fence
    cull none
    map textures/general_industrial/vent_grill1.tga
    alphafunc GE128
    rgbGen identity
    map $lightmap
    blendFunc GL_DST_COLOR GL_ZERO
    rgbGen identity
    depthFunc equal

    I hope that helps.

  7. #7
    Thanks, Acca, but I believe deckgrate_set1 on the catwalks is what The Shadow is using, and they don't work for him. The ventgrill issue was the first problem and I believe that is resolved, but now he's having issues with a single face not rendering when using deckgrate_set1. Usually, this can be fixed by applying no culling (cull none) inside the shader properties, but as we can see it's already there. I managed to break all of the stock map catwalks by recompiling, so it appears something else is causing this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts